psychopy.org | Reference | Downloads | Github

Calling up preferences (Ctrl+,) results in UnicodeDecodeError

OS: Win10
PsychoPy version: 1.85.3
Standard Standalone? (y/n): y
What are you trying to achieve?: I am trying to see (and change) my preferences.

What specifically went wrong when you tried that?: Here is the error message I get:

pyo version 0.8.5 (uses single precision)
Traceback (most recent call last):
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\app_psychopyApp.py”, line 611, in showPrefs
prefsDlg = PreferencesDlg(app=self)
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\app\preferencesDlg.py”, line 159, in init
specSection=self.prefsSpec[section])
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\app\preferencesDlg.py”, line 264, in makePrefPage
parent=panel, name=pLabel, value=thisPref, spec=thisSpec)
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\app\preferencesDlg.py”, line 375, in init
devs = sound.getDevices(‘output’)
File “C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\sound\backend_pyo.py”, line 66, in getDevices
for ii in allDevs: # in pyo this is a dict but keys are ii ! :-/
UnicodeDecodeError: ‘utf8’ codec can’t decode byte 0xe4 in position 4: invalid continuation byte

The error doesn’t show up in PsychoPy version 1.85.2 :face_with_monocle:
Might it be a bug in the new 1.85.3 version?

1 Like

Hello,

I’ve got the same problem with the newest psychopy version 1.85.3. as well on Windows 10 and on Windows 7, both German Version.
I can’t open the preferences and of course while trying to run an experiment with the microphone as response the same error as above appears.

1 Like

Hi,

it’s a relief to hear that I am not alone :wink: I am using the German version as well, if that is of importance.

Out of interest - could you try to play a sound with psychopy? Do you get the following error (see the link). In other words, are my two problems with Psychopy due to the same error?
https://discourse.psychopy.org/t/playing-a-sound-with-pyo-in-either-builder-or-coder/3006?u=lukaspsy

Yes, I get exact the same error message while trying to play a sound.

1 Like

It looks like some unicode issues must have crept into the branch for the 1.85.3 release, but I’m not sure how. I thin you’ll need to go back to 1.85.2 or wait for 1.86 (but not sure when that will be ready)

Thank you very much for your answer Jon :smiley:

If I set up an experiment in the builder version 1.85.3, will it be compatible with version 1.85.2 or do I have to create a new experiment?

Thanks as well! I will wait then for the next version. As I’m using text stimuli as well.

It seems that, since the change from 1.85.2 to 1.85.3 indicates only a bug fix, I can simply use the old version 1.85.2 in order to run my experiment according to the Psychopy website.

“Changes to the final digit (1.00.05 -> 1.00.06) indicate a bug-fixing release or very minor new features that shouldn’t require code changes from the user.”

Yes, version 1.85.2 -> 1.85.3 was (or should have been!) a bug-fix release and if you were not affected by the bugs you could stick with 1.85.2.

Alternatively, I’ve now uploaded a version marked as 1.85.4 which is actually the same as the intended 1.85.3 release:
https://github.com/psychopy/psychopy/releases

It looks like only Mac users should have been affected by the release error

Hi all!
Actually, I am experiencing this kind of error on Ubuntu 19.04 as well. The preferences were working before. It stopped after I downloaded some library or update, I’m not sure.
Here is the output:

Traceback (most recent call last):
File “/usr/lib/python2.7/dist-packages/psychopy/app/_psychopyApp.py”, line 611, in showPrefs
prefsDlg = PreferencesDlg(app=self)
File “/usr/lib/python2.7/dist-packages/psychopy/app/preferencesDlg.py”, line 159, in init
specSection=self.prefsSpec[section])
File “/usr/lib/python2.7/dist-packages/psychopy/app/preferencesDlg.py”, line 264, in makePrefPage
parent=panel, name=pLabel, value=thisPref, spec=thisSpec)
File “/usr/lib/python2.7/dist-packages/psychopy/app/preferencesDlg.py”, line 373, in init
from psychopy import sound
File “/usr/lib/python2.7/dist-packages/psychopy/sound/init.py”, line 69, in
from . import backend_pyo as backend
File “/usr/lib/python2.7/dist-packages/psychopy/sound/backend_pyo.py”, line 14, in
import pyo
File “/home/mmogam/.local/lib/python2.7/site-packages/pyo/init.py”, line 25, in
from . import _linux_wheel_fix_symlinks
File “/home/mmogam/.local/lib/python2.7/site-packages/pyo/_linux_wheel_fix_symlinks.py”, line 91, in
libjack = ctypes.CDLL(libjack, mode=ctypes.RTLD_GLOBAL)
File “/usr/lib/python2.7/ctypes/init.py”, line 366, in init
self._handle = _dlopen(self._name, mode)
OSError: /home/mmogam/.pyo/2.7_64/libs/libjack-07a61c7b.so.0.1.0: cannot open shared object file: No such file or directory

How to open Preferences if not using CTRL+, ?

@marimoga what version of PsychoPy have you installed? It looks like you’re installing into a Python 2 installation. COuld you switch to Python 3 and, preferably to a recent version of PsychoPy if you haven’t done that already.

The issue you’re seeing is nothing to do with the use of Ctrl+,. It’s most likely caused by a unicode character in the name of your audio card but this is something that I believe is fixed in recent versions

Hi Jon. Thanks so much for replying.
I am currently using 1.85.3. Will my code run on psypy3? Although I have tried to install the newest version before, I will install the Psychopy3 version. Is there a topic here where I can find the steps to safely remove this version?

You won’t be able to simply run your Psychopy1.8. code in Python3.2. Are you working with the builder or the coder option? In the coder you might be able to adapt your code to Psychopy3 if the experiment is not too complex.

Psychopy3 and Psychopy1.8 can be installed at the same time. They don’t interfere with each other.