psychopy.org | Reference | Downloads | Github

Builder suddenly stopped working

Hi

For some reason, I cannot launch python ./app/psychopyApp.py i.e. Builder
from the mac commandline.

import psychopy.locale_setup # noqa
ModuleNotFoundError: No module named ‘psychopy’

It was fine a few weeks ago. I pip-ed installed a few things but I am wondering what has changed to make it this way?

I know python has moved along to 3.9. Is it related to it somehow?

OS (e.g. Win10): mac sierra
PsychoPy version (e.g. 1.84.x): don’t know
Standard Standalone? (y/n) If not then what?: custom built

Are you opening from a different directory than usual? If you check site-packages is the psychopy folder still there?

Yes, it’s still there. But it’s under a 3.7 python dir.

/Users/me/python_environments/psychopy/lib/python3.7

But python is 3.9
/Users/me/python_environments/psychophysics/psychopy/bin/python
Python 3.9.4 (default, Jun 23 2021, 19:11:44)

I don’t remember actively installing a newer version of python but it could have happened as part of other dev work. I cloned a new version of psychopy and installed that but it gave me the same error. Do you have any suggestions on what i could do to upgrade psychopy so that I see a 3.9 version of python in the site-packages?

There is no psychopy inside of /Users/me/python_environments/psychophysics/psychopy/lib/python3.7/site-packages

Should there be? What can i install that would put it back (if it should be there)?

Hi,

After working on this problem, I think there is a problem with setuptools (contains pkg_resources) and python 3.9. Has anyone else moved to python 3.9 and successfully worked off builder?

An error that I am seeing which is associated with the above:
from pkg_resources import parse_version
ModuleNotFoundError: No module named ‘pkg_resources’

thank you

Ok, I solved this issue. python3.9 has arrived! and you need to update all the site modules including a bunch of sub-modules. Closing this.