psychopy.org | Reference | Downloads | Github

Bug: disappearing line breaks in code cells in Builder

Yep. Can confirm that the new lines are now respected and remain stable from pasting in, saving, quitting, reopening on Mac. And that works when the source text is LF (default in Atom) or CRLF. With CRLF you still get additional new lines injected in, but that’s not an issue for me as I just use the default LF. (Didn’t even know what LF or CRLF was before this :slight_smile: )

So, thumbs up for all working correctly on Mac. Can’t tell on PC at this point, but happy to test when 3.0.5 becomes available for PC.

I’m absolutely amazed to hear that any editor is still providing old Mac EOLs. The fact that windows text editors like Notepad still don’t recognise LF is less of a surprise. :wink:

Getting people to use Atom, Sublime or Notepad++ is the best solution.

Yep, I’ve got Atom as the only text editor on my lab computers. So it’s either that or VS Code which I sometimes use on my personal machines.

3.0.5 is now released. We’re actually not 100% certain that this issue is fixed, but we think there has been progress!

1 Like

Great stuff. I’ll check re the PC side of things when I’m next able to get back into the lab and report back :slight_smile:

Sorry it’s taken a while. I’ve had broader issue with the lab PC.

In 3.0.5, pasting python code into a code block on a Mac, saving, quitting, reopening, then the line breaks are preserved. Opening the same file on a PC (also with 3.0.5) also has preserved line breaks.

So I believe this is successfully resolved! Thanks all for your speedy help. Much appreciated.

Just one very minor gripe… on the PC only the ‘show EOLs’ option in the coder view seems to always default to true, so you always get the LF characters. But I can get on with things nicely though :slight_smile: