AttributeError: 'MovieStim3' object has no attribute '_texID'

Hi I’m new to psychopy and trying to build an experiment with video stimuli. I have tried the MovieStim demo in the standalone Psychopy, it can successfully run the video. But when I tried the demo in another Psychopy(I installed through miniconda), it returns the error:
There is a similar question here, but the solution doesn’t solve my problem:

I’m using Mac

When I run:
mov = visual.MovieStim3(win, ‘jwpIntro.mp4’, size=(320, 240),
flipVert=False, flipHoriz=False, loop=False)
while mov.status != constants.FINISHED:
if event.getKeys():

It shows:
Exception ignored in: <bound method MovieStim3.del of <psychopy.visual.movie3.MovieStim3 object at 0x7fd475dd8710>>
Traceback (most recent call last):
File “/Users/wuyichen/opt/anaconda3/envs/psychopy/lib/python3.6/site-packages/psychopy/visual/”, line 568, in del
File “/Users/wuyichen/opt/anaconda3/envs/psychopy/lib/python3.6/site-packages/psychopy/visual/”, line 545, in _unload
File “/Users/wuyichen/opt/anaconda3/envs/psychopy/lib/python3.6/site-packages/psychopy/visual/”, line 1270, in clearTextures
GL.glDeleteTextures(1, self._texID)
AttributeError: ‘MovieStim3’ object has no attribute ‘_texID’

Thanks for your help!!

I found my way to get away with it:

(1) Simply just used Windows pc instead of Mac, the problem solved.
(2) In Mac, the MovieStim3 function works well in the standalone Psychopy.

1 Like