psychopy.org | Reference | Downloads | Github

Another one with the issue of "ImportError: No module named json_tricks"


#1

I am having the same error as reported here: ImportError: No module named json_tricks

I posted in the thread, but got no response:

I get the same error as the 2 other posters. It seems that my pip leads to my conda installation by default.

Running (inside the coder)

import sys
print(sys.executable)

returns

/usr/bin/python

but when I try

/usr/bin/python -m pip install json_tricks

it returns

/usr/bin/python: No module named pip

Is there a way for me to address this? Tried to reinstall psychopy to no avail.

I hope that someone can help me


#2

Hi @simon.dp, you could try and install pip into that installation of Python:

/usr/bin/python -m easy_install pip

And then try again with pip. See here for setting up easy_install if ez_setup is not installed.


#3

Hi @dvbridges

Thanks for your response. I’ve have tried a few a approaches, but none that got me further.

/usr/bin/python -m easy_install pip

returns
/bin/python: No module named easy_install

So I followed your link leading me to try the

pip install setuptools

which returned
Requirement already satisfied: setuptools in ./anaconda3/lib/python3.6/site-packages (38.4.0)

Finally, I tried to download the ez_setup.py file and run it with the command
python ez_setup.py

That returned

  File "ez_setup.py", line 106
    except pkg_resources.VersionConflict, e:
                                        ^

So it seems that I already have setup tools but it is connected with my conda package.

Help to progress from here is much appreciated.