psychopy.org | Reference | Downloads | Github

All of a sudden: problems with running or even downloading video files online

URL of experiment: https://pavlovia.org/MS/3_3_vor_experiment

Description of the problem: Hello, I encountered the following problem: for the last two weeks I’ve been running a new experiment (after 2 very similar, successfully running ones). This experiment contains 6 different videos (each 54 Sec in total). Since 3 days there have been problems, though, with running video files. Before, everything worked fine.

Now, participants are either not able to download the files, then comes the following error message:
"Unfortunately we encountered the following error:
-when downloading the resources for experiment …
-unable to download resource: videos/Car.mp4(FILE_LOAD_ERROR)

In other cases, the files are downloaded, the experiment runs normally, except that some video files get stuck. Once it even happened that the same video was shown instead of all the others (when usually each video is shown only once) = means, that when actually video 2 then 3 then 4… should have been shown, it was always video 1.

This has happened to all participants since 3 days, but for me the experiment runs fine on both my laptops (one being a lenovo thinkpad, one a macbook; one being the source laptop, one a random one)

I tried to track back what could have happened 3 days ago to suddenly cause these errors. Maybe it’s connected to the fact that one student of mine was in charge, but got lost on the github page. As far as I can see, though, nothing has been changed there.

Let me know, if you need more information.

Thanks in advance for any help or advice!

Paula

Hello Paula,

you project is not accessible: “No information available for this experiment: it may not exist or you may not have access to it.”

What do you mean with

Cheers Jens

Hello Jens,

thanks for your reply!

Strange. It should work. It’s set to “Running”. Do I have to change anything else in the settings in order for people here to access it?

Sorry, I wrote very unclear. I meant, that on the day it started, one student was in charge of running the experiment. He opened Pavlovia for the first time. In the tutorial he only watched. For some reason he didn’t open the “normal” pavlovia page (with dashboard etc.), but went directly to Gitlab (not github of course, sorry for the mistake). He didn’t know he was on the wrong page. He just thought he forgot what it looks like and so he clicked his way through to find what he was looking for (the experiment-link).
I thought that maybe he accidentally changed some file/some structure?
So far I couldn’t find anything, but I also don’t really know my way around in Gitlab, so I cannot really tell.

Thanks again,
Paula

Hello Paula,

setting the experiment to running allows participants to run your experiment. You have to grant access to the project.
Starting from the Dashboard -< View Code -> Settings -> Permissions -> Public

Best Jens