2nd loop for learning phase not working

URL of experiment: https://gitlab.pavlovia.org/nreynoso/lisbhi2

Description of the problem: My experiment worked fine in the builder, but I am running into issues in pavlovia. This experiment is where we will teach subjects matchings between stimuli. There are two rounds where subjects get taught word-video matchings. When the 2nd round of matchings are presented, after being shown word and a fixation cross, the 1st video freezes. I do not get an error message so I am not certain what is the issue?

Are you using the same routine for the practice and matching videos?

Is the video a repetition?

Is it encoded the same way?

Best wishes,


The practice round follows the same format (fixation cross, word, fixation cross, word and video presented on the same screen), but draws from a different spreadsheet. The two learning loops after that initially drew from the same spreadsheet, but I tried making a duplicate spreadsheet for the 2nd round (and appropriately changing the name of the spreadsheet the 2nd loop was pulling information from) and was still running into the same issue with the video in the 2nd loop freezing. The videos in the 2nd loop are repeats of the 1st loop.

I’m not too sure what you mean by encoding, but all the videos are in mp4 format.


An issue with videos failing to replay has come up here:

If that works for you I’ll add it to my crib sheet.

1 Like

Copy of Experiment Code: gitlab project

Thank you for the suggestion. Unfortunately I tried inserting a code component with movieName.play(); and movieName.stop(); for the routine where the video is presented a 2nd time and looped, however I kept getting an error message “TypeError: Cannot read property ‘play’ of undefined” when I piloted the experiment.

When I removed movieName.play(); like another person did in that thread, I did not get an error message, but my video was still frozen and did not repeat. Adding movieName.reset() at the end of the routine also did not solve this issue.

By movieName do you mean the name of the file or the name of the component? It should be the latter,