Urgent: Study Won't Initialize

URL of experiment: https://run.pavlovia.org/bpc04a/seqdotarray32/html

Description of the problem: My experiment has stopped initializing when participants arrive. I have no idea why. Everything appears in place in the github repository.

Here is a link to cloning the files: https://gitlab.pavlovia.org/bpc04a/seqdotarray32.git

I would so deeply appreciate any insights.

That usually represents an error in the Begin Experiment code.

Check the console for errors.

If you are using my crib sheet and have just updated your version it could be because you are defining round in code_JS which is no longer needed.

Hello Benjamin,

call the debugger by pressing F12 (Chrome, Firefox on Win10). There is an error (/**********************) in [SeqDotArray32.js:1:1. See here how to find an js-error.

Best wishes Jens

Does that just mean removing the “const { round } = util;” line?

I meant removing it from the experiment file, not the JS file.

Your error is that it looks like you’ve manually edited or corrupted your js file with extra characters:

So I went into the WebIDE and removed the “” characters from the file (no idea how that happened to begin with). Tried to run the experiment again and got the same result. Still stuck initializing and still throwing the exact same error. I double-checked that I had committed the most recent change. The file no longer includes the corruption, so I’m pretty confused.

Hard refresh (Ctrl-Shift-R) to get past that error.

It’s currently downloading 418 resources for me.

You’re my new favorite person. “Thank you” is a woefully underequipped phrase to convey my appreciation in this moment.

1 Like