Uploaded video files have .icloud at the end, code not recognizing files

URL of experiment: Pavlovia

Description of the problem: When I upload my video stimuli to Pavlovia “.icloud” is appended to the end of the file. I assume that the videos are too big and get uploaded to the cloud. Is there a way to have Pavlovia not do this? Since they are in the cloud, my online experiment has trouble finding the files and gives me the following error when the video is supposed to play:

Unfortunately we encountered the following error:

  • when setting the movie of MovieStim: movie
  • bplist00�\NSURLNameKey_NSURLFileSizeKey_NSURLFileResourceTypeKey_!Exp2_007_baseline_10cbr_25fps.mp4��|_NSURLFileResourceTypeRegular/Jnsa� is not a video

I did change my file names in my .csv sheets that retrieve the videos so that it recognizes the .icloud files.

SOLVED: On mac, files are sometimes uploaded to the cloud. When I uploaded my experiment, all my video stimuli were in the cloud and only their “.icloud” files were uploaded. I just uploaded the files manually to the gitlab file.