psychopy.org | Reference | Downloads | Github

Upgrade failed - "TypeError: String or Unicode type required"

On PC Windows 10 (with latest updates), I am trying to upgrade PsychoPy2 from v1.85.1 to v.1.85.2.

Home computer, vanilla set-up, logged in as administrator, no VPN or proxy.

Choosing “auto-install” option.

Get error:

Traceback (most recent call last):
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\psychopy\app\connections.py", line 396, in onInstall
self.statusMessage.SetLabel(info)
  File "C:\Program Files (x86)\PsychoPy2\lib\site-packages\wx-3.0-msw\wx\_core.py", line 9207, in SetLabel
return _core_.Window_SetLabel(*args, **kwargs)
TypeError: String or Unicode type required

PS. Not sure which forum category this goes in.