Unspecified JavaScript error: works in some computers but not others

@sotiri believe I’ve done it right, experiment is just stuck on initialising page though?

@bloxham99 OK there seems to be an error in your script unrelated to the above edit, let me see

@bloxham99 It’s the psychoJS.setRedirectUrls(...); call that is causing it to trip. It looks as if you were trying to comment that out?

@sotiri the Pavlovia study is redirected from a Qualtrics survey and also terminates into another Qualtrics survey - the edit of the completion link is the only modification I made to the Psychopy experiment since two weeks ago. I followed pages on here to try and get the redirect links to work smoothly but could well have done something wrong?

@bloxham99 No problem, yes the string you are passing in is formatted incorrectly, could you give me the url you would like to redirect to so I can try to fix it? x

@sotiri of course, this is the survey https://unioflincoln.eu.qualtrics.com/jfe/form/SV_08LMsB7kMVqH4rP and then I added expInfo[‘participant’] to the end to carry my participant ID back through to Qualtrics (followed instructions from a crib sheet in here but think this is probably where I’ve messed it up :see_no_evil:)

OK :blush: @bloxham99 I have updated the support fork, could you try amending line 88 to match and post back if any problems remain?

@sotiri copied the line 88 linked into the same section of my code and still stuck on initialising, says due to a syntax error. Is this done correctly? Sorry I’m clueless.

FYI, I think the error you all are discussing here is the same or at least related related to the one that I raised in this thread.

EDIT: I initially thought that my work computer’s Chrome and Edge were throwing the same error, but now I don’t think so. I tried to run this very simple test experiment https://gitlab.pavlovia.org/atryan/migt-v1-05 and it worked, so it really does seem to vary from computer to computer.

Hi @bloxham99, as you can see in the screenshot attached the script that is currently running on Pavlovia is the same as before, were you able to sync your project successfully post edit?

@sotiri I amended the code on gitlab did I need to do it on Psychopy?

@bloxham99 I would expect that you need not to, but as it happens it might be better if you tried? x

@sotiri I realised I didn’t amend the code for the .js file for legacy browsers so just tried that but to no avail :weary: this is the syntax error I’m getting?

@bloxham99 Alright, cool, yes that looks like the same type of error, you seem to be running a fairly recent version of Chrome on macOS, the legacy build should not come into play. It must be that Pavlovia and GitLab are out of sync

@bloxham99 Sorry, which version of your study would you rather stage? Is it the html folder one, because the redirect url part on that script remains unchanged?

@sotiri I did but for some reason the changes to the html file did not commit, it runs now without the Javascript error but I have this error instead? If completely unrelated I will post a new thread as I understand I have taken a lot of your time but I have no idea what this means?

@bloxham99 No problem, here to help, please allow me some time to investigate :nerd_face:

@sotiri Thankyou. On instruction from my supervisor I have had to modify the experiment so that it goes SONA → Qualtrics → Pavlovia now (just to simplify things down on their end) & I have edited code accordingly (as this meant changing the completed URL redirect link - I think I’ve done this correctly), still getting the FrameDur issue, even when I run the experiment from the dashboard, which has never happened. :tired_face:

@bloxham99 It sometimes happens when exporting HTML from PsychoPy that some variable definitions are missing, like frameDur in this case. If you add var frameDur; just above experimentInit() for example that should take care of this particular error, but I’m a little worried there may be more variables undefined like that :thinking:

@sotiri unfortunately it seems to be the case.

is this something I’ve done wrong? I’ve always synced between Psychopy and Gitlab in the same way.