psychopy.org | Reference | Downloads | Github

Trying to run OpenSource IRAP built in PsychoPy v1.85 in v3.0.1

I’m trying to get this IRAP (written in PsychoPy 1.85) to run in PsychoPy3.0.1. This is the GitHub link to Ian Hussey’s code:

He mentions that newer versions of PsychoPy will need to run the .py file rather than use the .psyexp file. Tried doing this today and I just get the following pop up in my output:


###### Running: C:\Users\chris\Desktop\OpenSourceIRAP-0.9.11\code test.py ######

Nothing else happens. In contrast, if I run the .psyexp file the task actually starts up but errors out after the instruction screen and I get the following:

Traceback (most recent call last):
  File "C:\Users\chris\Desktop\OpenSourceIRAP-0.9.11\OpenSourceIRAP-0.9.11\Open Source IRAP_lastrun.py", line 1162, in <module>
    if not isinstance(required_allowed, basestring):
NameError: name 'basestring' is not defined

I know enough Python to adjust the parameters etc. but just need some help getting the task up and running to being with (famous last words).

Any help appreciated!

Cheers
CK

When I open the .psyexp file it seems to run fine in the latest version (2021.1.0), could be that this is outdated advice which at one point applied but no longer does as we’ve enhanced backwards compatibility since. Running the psyexp should be safer, as we can put in code to interpret old experiment files and generate up to date Python but can’t do the same in reverse.