Psychopy not Opening on Linux

I tried installing Psychopy on Linux Ubuntu 22.04 distro.
Even though it shows the application, it does not open. When I type in the console:

open psychopy

I get the error:

gio: file://home/user/psychopy: Error when getting information for file "/home/user/psychopy": No such file or directory

I not uninstalled psychopy and tried to reinstall it:
with pip install psychopy I get the following error:

  error: subprocess-exited-with-error
  × python egg_info did not run successfully.
  │ exit code: 1
  ╰─> [8 lines of output]
      Traceback (most recent call last):
        File "<string>", line 2, in <module>
        File "<pip-setuptools-caller>", line 34, in <module>
        File "/tmp/pip-install-2a8c_cls/wxpython_2581af1efb9d472f9d38db2f56e981e2/", line 27, in <module>
          from buildtools.config import Config, msg, opj, runcmd, canGetSOName, getSOName
        File "/tmp/pip-install-2a8c_cls/wxpython_2581af1efb9d472f9d38db2f56e981e2/buildtools/", line 30, in <module>
          from attrdict import AttrDict
      ModuleNotFoundError: No module named 'attrdict'
      [end of output]
  note: This error originates from a subprocess, and is likely not a problem with pip.
error: metadata-generation-failed

× Encountered error while generating package metadata.
╰─> See above for output.

note: This is an issue with the package mentioned above, not pip.
hint: See above for details.

I am assuming you are using Python 3.10. Even though they closed my bug report (Incompatibility with Python 3.10, wx, and implicit conversion to integers · Issue #5015 · psychopy/psychopy · GitHub), there are still a bunch of bugs in PsychoPy related to the change to implicit conversion to integers that happened in 3.10. There are instructions for getting it working with Python 3.8 How to install PsychoPy 2022.1.4 on Ubuntu 22.04 using virtualenv