psychopy.org | Reference | Downloads | Github

PsychoPy can't work in windows10 version1903

I’m using Windiows10 version1903(OS build 18362.207) and PsychoPy3 version3.1.3.
Few days ago, I’ve updated windows from 1809 to 1903.
Then, PsychoPy can’t work.
Someone please help me.


PsychoPy3へようこそ!
v3.1.3

Running: D:\Sato_Seminar\Program Files\PsychoPy3\lib\site-packages\psychopy\demos\coder\basic\hello_world.py

pygame 1.9.4
Hello from the pygame community. https://www.pygame.org/contribute.html
1.9570 WARNING Monitor specification not found. Creating a temporary one…
Traceback (most recent call last):
File “D:\Sato_Seminar\Program Files\PsychoPy3\lib\site-packages\psychopy\demos\coder\basic\hello_world.py”, line 14, in
win = visual.Window()
File “D:\Sato_Seminar\Program Files\PsychoPy3\lib\site-packages\psychopy\visual\window.py”, line 389, in init
self.backend = backends.getBackend(win=self, *args, **kwargs)
File “D:\Sato_Seminar\Program Files\PsychoPy3\lib\site-packages\psychopy\visual\backends_init_.py”, line 32, in getBackend
return Backend(win, *args, **kwargs)
File “D:\Sato_Seminar\Program Files\PsychoPy3\lib\site-packages\psychopy\visual\backends\pygletbackend.py”, line 227, in init
self._origGammaRamp = self.getGammaRamp()
File “D:\Sato_Seminar\Program Files\PsychoPy3\lib\site-packages\psychopy\visual\backends\pygletbackend.py”, line 329, in getGammaRamp
return getGammaRamp(self.screenID, self.xDisplay)
File “D:\Sato_Seminar\Program Files\PsychoPy3\lib\site-packages\psychopy\visual\backends\gamma.py”, line 128, in getGammaRamp
raise AssertionError(‘GetDeviceGammaRamp failed’)
AssertionError: GetDeviceGammaRamp failed
Exception ignored in: <bound method Window.del of <psychopy.visual.window.Window object at 0x000002195E0ED208>>
Traceback (most recent call last):
File “D:\Sato_Seminar\Program Files\PsychoPy3\lib\site-packages\psychopy\visual\window.py”, line 501, in del
self.close()
File “D:\Sato_Seminar\Program Files\PsychoPy3\lib\site-packages\psychopy\visual\window.py”, line 1327, in close
self.backend.close() # moved here, dereferencing the window prevents
AttributeError: ‘NoneType’ object has no attribute ‘close’

Same problem with you.
Have you solve it?

I think other window type(winType=‘pygame’ or ‘glwf’) can work.

if you have more than one monitor connected, remove it and see if you still get the error.

Thank you for your information. I have tried your method, it works. Actually, you don’t need to remove the dispaly connection, the display setting is the key. Only the ‘extend these displays’ in display setting introduce this bug. Other display setting (duplicate or show only in one) works well.

1 Like