psychopy.org | Reference | Downloads | Github

Pavlovia not loading

pavlovia
linux

#1

OS: Fedora 29
PsychoPy version : 3.0 installed through conda
What are you trying to achieve?:
Sync with pavlovia. However, when I try to login the following message appears:

Unable to load page
Problem occurred while loading the URL https://gitlab.pavlovia.org/oauth/authorize?client_id=4bb79f0356a566cd7b49e3130c714d9140f1d3de4ff27c7583fb34fbfac604e0&redirect_uri=https://gitlab.pavlovia.org/&response_type=token&state=25679d58-4dd6-468e-bf78-9ee3630c39bc

TLS/SSL support not available; install glib-networking

What did you try to make it work?:
Tried to install the glib-networking through the commands below. The instalation was fine but the message persisted.

sudo dnf install glib-networking
conda install -c anaconda glib-networking-cos6-x86_64

Opening Builder via Anaconda on Linux
PsychoPy3 on Linux installation issues (solved)
#2

Sorry, don’t know enough about Fedora to know why this doesn’t work. What if you go to a terminal (or a browser) and try that link? Does it work there?


#3

Hi, thank you for helping.
But I don’t think it is specific to Fedora. Here, someone had the same problem with Linux Mint (https://github.com/psychopy/psychopy/issues/1979).

I tried the link on browser and it opens pavlovia home page. On terminal:


[andresimi@andredesk ~]$ https://gitlab.pavlovia.org/oauth/authorize?client_id=4bb79f0356a566cd7b49e3130c714d9140f1d3de4ff27c7583fb34fbfac604e0&redirect_uri=https://gitlab.pavlovia.org/&response_type=token&state=25679d58-4dd6-468e-bf78-9ee3630c39bc
[1] 12617
[2] 12618
[3] 12619
bash: https://gitlab.pavlovia.org/oauth/authorize?client_id=4bb79f0356a566cd7b49e3130c714d9140f1d3de4ff27c7583fb34fbfac604e0: Arquivo ou diretório inexistente
[2]-  Concluído              redirect_uri=https://gitlab.pavlovia.org/

#4

Any thoughts on this? I tried on Ubuntu and it is the same. Maybe it is related to Anaconda? Unfortunately I could not install through pip…