Pavlovia doesn't sync

URL of experiment: ASL Experiment ASL Experiment

Description of the problem: When I pulled the data for experiment asl-joint-500ms-gap-2bl, the index.html, the jspsych folder and much of the stimuli from the sound folder disappeared. In the repo this happened at commit e0997af4. But apart from the deleting, whe data were downloaded so no data was lost. But since then something is wrong with the sync.

First, the asl-joint-500ms-gap-2bl experiment still runs, without index.html and the stimuli in the repo. Second, and this is what makes this a problem, ever since the pulling incident my new experiments are constantly having syncing problems: when trying to run a new experiment, asl-phan-500, it can’t see the stimuli in the sound folder (although they are in the repo) and fails to load. The code for the two experiments are almost identical (the header and calling pavlovia are exactly the same). I’ve also tried clearing the cache but it didn’t help.

Are you using the same folder for multiple experiments?

Use Ctrl Shift R to run the latest version of your code.

Thank you for your answer.

These are two different folders (two separate projects in gitlab). The titles are the same but the urls are different, corresponding to the gitlab projects ( asl-joint-500ms-gap-2bl and asl-phan-500).

I’ve tried Ctrl Shift R and all the other suggestions for clearing the cache in the crib sheet (PsychoPy Python to Javascript crib sheet 2021 - Google Docs).

Clicking on your links I’ve noticed that your experiments must be written in jsPsych (I know you implied this) so I’ve added the appropriate tag.

Yes, that’s right, thanks.
Is there any additional info needed? Should I share my repos?

Hello @beatatunde ,

I have just emailed you with more information but I believe that the issue has been solved. At the very least, ASL phan 500 v2 is now in RUNNING mode.
Do let me know if the problem persists, of course.
Best wishes,