Online experiment no longer updating / 403 error / 404 error

URL of experiment:

Description of the problem: My original experiment had issues with textboxes (see Buttons and textboxes not clickable online - Online experiments - PsychoPy) so I replaced the textboxes with images and this solved the problem in a minimal example. When I tried to implement that change in my real experiment it worked fine offline, but the online version of the experiment did not update. Syncs were successful and the files on Github were up to date. However, when piloting the experiment it still run the old version.

As a work around, I tried to copy the essential files (stimuli, psyexp) of the experiment to a new folder on my computer and create a new project on Pavlovia. I deleted the old project on Pavlovia and Github (not locally). The new experiment runs fine offline, sync was successful, but I got a 403 error when trying to run it online. I tried changing status from pilot to inactive and to pilot again but with no luck. I tried synching again and now I get a 404 error. The html folder has the js files and html.index files.

I feel like I’m stuck in an endless loop of errors. Can someone please get me out of here?


Unfortunately, I experience exactly the same problem. Although the GitLab page is updated, when piloting or running the experiment, it is still using the old version.

Try Ctrl-Shift-R or an incognito tab to run the latest version.

Incognito tab doesn’t make a difference. I still get a blank screen and “Failed to load resource: the server responded with a status of 404 ()” as an error in development tools.
I’m not sure what you mean by Ctrl-Shift-R. I pressed this combination while on the Experiment page on Pavlovia from which I normally run/pilot the experiment. It just refreshed the page.

Sorry – I wasn’t clear on your error so I focussed on

Here are two links you should follow:

Thanks, I have tried the advice given in the first link: replaced bmp images by png and specify all images as additional resources in the online tab of the experiment settings. Unfortunately, things got worse. Offline all still works fine, but I can no longer sync my experiment with Pavlovia from the builder. I get the following error:

Traceback (most recent call last):
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\builder\”, line 1372, in onPavloviaSync
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\builder\”, line 808, in fileExport
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\scripts\”, line 71, in generateScript
compileScript(infile=exp, version=None, outfile=filename)
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\scripts\”, line 245, in compileScript
_makeTarget(thisExp, outfile, targetOutput)
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\scripts\”, line 217, in makeTarget
script = thisExp.writeScript(outfile, target=targetOutput, modular=True)
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\”, line 286, in writeScript
self_copy.settings.writeInitCodeJS(script, self_copy.psychopyVersion,
File "C:\Program Files\PsychoPy\lib\site-packages\psychopy\experiment\components\settings_init
.py", line 834, in writeInitCodeJS
with open(os.path.join(folder, “index.html”), ‘wb’) as html:
PermissionError: [Errno 13] Permission denied: ‘C:\Users\vhsx41\OneDrive - Durham University\OxVPS 2.0\Online reading2\index.html’

Sync from the editor seems to work: I get a ‘success’ message, but only the .py and .psyexp files are updated, not the html folder with js files.

I tried the second solution on a different copy of the project, but again cannot synch it to Pavlovia or Github. The error I get here is
Traceback (most recent call last):
File “C:\Program Files\PsychoPy\lib\site-packages\gitlab\”, line 304, in wrapped_f
return f(*args, **kwargs)
File “C:\Program Files\PsychoPy\lib\site-packages\gitlab\”, line 112, in get
server_data = self.gitlab.http_get(path, **kwargs)
File “C:\Program Files\PsychoPy\lib\site-packages\gitlab\”, line 662, in http_get
result = self.http_request(
File “C:\Program Files\PsychoPy\lib\site-packages\gitlab\”, line 628, in http_request
raise gitlab.exceptions.GitlabHttpError(
gitlab.exceptions.GitlabHttpError: 404: 404 Project Not Found

The above exception was the direct cause of the following exception:

Traceback (most recent call last):
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\projects\”, line 633, in project
self._project = self.session.gitlab.projects.get(
File “C:\Program Files\PsychoPy\lib\site-packages\gitlab\v4\objects\”, line 782, in get
return cast(Project, super().get(id=id, lazy=lazy, **kwargs))
File “C:\Program Files\PsychoPy\lib\site-packages\gitlab\”, line 306, in wrapped_f
raise error(e.error_message, e.response_code, e.response_body) from e
gitlab.exceptions.GitlabGetError: 404: 404 Project Not Found

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\builder\”, line 1377, in onPavloviaSync
pavlovia_ui.syncProject(parent=self, file=self.filename, project=self.project)
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\pavlovia_ui\”, line 665, in syncProject
if not project.localRoot:
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\projects\”, line 716, in localRoot
if self.project.path_with_namespace in knownProjects:
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\projects\”, line 636, in project
raise KeyError(f"Could not find GitLab project with id {}.")
KeyError: ‘Could not find GitLab project with id 214436.’

Any help is much appreciated.

Thank you,