| Reference | Downloads | Github

New ErrorMessages after Pavlovia Esc Changes July 2020

all of my Experiments that had been working a couple of weeks ago now do not seem to work anymore in Internet Explorer. At the beginning of each Experiment I get the Error Message:

TypeError: Object doesn’t support property or method ‘escape’

The rating studies I had created still work in Firefox, but I also created an experiment that is collecting keypresses. This one does not work properly anymore, even in Firefox. My Impression is that there have been some changes to how keypresses are encoded in JavaScript? Does anybody have some idea?
Thanks a lot

There has been a specific change to the escape key. You can now switch on and off whether your experiment saves partial data. Do you have any code related to escape or aborting the experiment?

Thanks for your reply. No, there is no code related to the escape key except for the implemented ‘enable escape key’ in the experimental settings. I have switched that on and off though - it does not make a difference.

Escape in programming language also means backslash \

Have a look at the console to see if you can pin down which line is causing the error.

Okay, thanks, will check the code. Console won’t work, because it’s an error message that only pops up online when running it on Pavlovia. But just on a side note - isn’t it weird that all these experiments that worked perfectly well online and offline a few weeks ago, now have this same problem? Somehow nobody else seems to face this issue - at least I did not find other posts, so I don’t know what’s going on.

Please look at my crib sheet (pinned post) for how to view the console online.

If it’s just your experiments that have broken then it’s either related to your account or a piece of code you frequently use.

Haha, I know your crib sheet! - it has helped me a lot so far but apparently I haven’t read it close enough. Thanks for creating it though - it is really helpful

By the way: I got an update from Internet Explorer to Microsoft Edge today, and this solved my error message (TypeError: Object doesn’t support property or method ‘escape’) - it does not appear anymore. Seems to have been a browser-internal problem somehow. This still doesn’t solve my key-collecting issue, but in the meantime I have realized that the issue is very specific to this experiment. I will try to work it out, but in case I should not be able to solve it, I might come back to you, if you don’t mind? Of course I will provide the code and precise problem :slight_smile: But let’s see, maybe I can solve it myself…