.js file not being created

Windows 10
PsychoPy v2021.2.3

Hi All,

I just recently downloaded the newest version of PsychoPy, and when I try to sync it to Pavlovia, it gives me this error message:

I looked in my local folder, and while the PsychoPy file is there, there is no js file. I have tried to compile the js script before trying to sync, but get the same error message.
I also looked on Pavlovia, and my project is showing up, but is shown as being version 2021.1.4, which is a problem because I want to use the microphone component in my online experiment.

I am very new to PsychoPy, and so it could be that I’m missing something obvious, but I would appreciate any help!

Try syncing from a local drive instead of OneDrive.

Hello, thank you for such a quick response. I’m a bit confused, because my experiment file is saved in my local drive, and I don’t even have OneDrive turned on. How do I prevent it from trying to pull the file out of OneDrive? I’m sorry about the trouble.

Did you move it from your OneDrive?

Try deleting the hidden .git folder or resyncing from Pavlovia. Basically you need to recreate to connection so it isn’t trying to look on your OneDrive.

I did not move it from OneDrive, but saved it from the beginning to my hard drive.
I’m not sure where the hidden git folder would be. Also how do you resync from Pavlovia? I can’t seem to find that option on my experiment page or on my git page?
I’m sorry to keep asking these basic questions, but I really appreciate your help here.

To find the .git file you need to reveal hidden files (how you do this differs by operating system - so google how to do that for your specific setup), the .git file is essentially what is telling psychopy that this file already has an associated project on pavlovia, so deleting it will “disconnect it”.

To resync to pavlovia, open up psychopy builder and use the :pavlovia_sync: icon be sure to use a new project name to what you used the first time.

PS. I removed the tag “jspsych” because that’s a different software, I think you may have means psychojs which is the counterpart of psychopy - easily confused!


Thank you for explaining that, and for removing the tag (I did get that confused).
So I deleted the hidden .git folder, deleted my experiment on Pavlovia as well, retried syncing anew from PsychoPy, and made sure that I made the source directory not on OneDrive, but I’m having the same issues. I also reinstalled PsychoPy 2.3 (and restarted my computer) but 1) it is giving me the same error message, 2) there is no .js file to be found anywhere, and 3) although the project appears on Pavlovia, I cannot open it…
Thanks so much for your time.

I fixed (?) my issue. I still do not know what exactly was going wrong, but I created a new experiment file and now it is generating a .js file and is showing up as the correct PsychoPy version on Pavlovia.