psychopy.org | Reference | Downloads | Github

Identical Computers and Same Program but Different Output

I have a bizarre issue with a newly purchased set of computers that I will do my best to describe. My lab purchased 2 brand new Dell laptops (specs below) and have identical OSs and versions of Psychopy (3.2.4) installed on them.

The two laptops have an identical program installed on them (uploaded from the same flash drive) and initially were working perfectly but one now displays a different output than the other. Namely this has to do with sizing. The computer on the left displays the correct size, but the computer on the right does not. Further, the computer on the right won’t change any elements of its display even after I change the size of the font (or anything else). Also, the computer on the right crashes every time a tone is sounded in the program, but the computer on the right does not. I have tried reinstalling psychopy and the programs but receive the same issue. It almost seems like the computer on the right is somehow “stuck” in the experiment it displays, even though I’ve altered elements of it. Anyways, I’ve attached a number of images of error messages I have received that come up when I start the experiment, when it crashes, and when I terminate it. I plan to have our IT guy wipe the computer entirely, but I’m wondering if there is any ideas how this might be happening on the software side of things.

I should add, the program is set to run on version 3.0, because I much prefer the data output from the older versions of psychopy. I still get the same issue when I switch to “run the latest version.”

Thanks.