psychopy.org | Reference | Downloads | Github

Fix for pyxid in 1.84.2

As it turns out, the pyxid version included with 1.84.2 only works with 1.83.4 (and older). Apparently, 1.84.x ships with a newer version of pyserial, which slightly changed its API. The pyxid devs already fixed their package. Therefore, using the current master of pyxid in combination with 1.84.2 resolves this issue. This also solves #1144 (and probably also #1170).

1 Like

Oh dear. So I have to go back to shipping the latest pyxid not the previous one. I changed the version after the github issue suggesting the new one was the broken one. OK, reverting to newest will be done in 1.84.3 but not immediately [sigh]

1 Like

I can totally hear you. We will be moving away from the standalone package anyway - this should resolve such dependency issues. Sorry for the inconvenience.

1 Like