Experiment downloading but not running, "file not found" message appearing

I am new to PsychoPy so please bear with me - I am also not the best at programming so I’m likely to not understand many terms.
I have had someone create an experiment, and send it to me in a ZIP file. When I decompress the ZIP file (which I think I have done correctly), the experiment opens in PsychoPy. However when I click the green triangle to run the experiment, an error message on my Mac (not in the PsychoPy error box) appears stating “File Not Found Error” with sub-text of Cannot run script ‘/Users/alicegamble/Downloads/BB-test_lastrun.py’, file not found!

The line in the PsychoPy error box is:
File “/Users/alicegamble/.psychopy3/versions/psychopy/visual/backends/gamma.py”, line 16, in

To fix it I have tried to resave the files to my Mac as you would normally do, ensured PsychoPy is the correct version for my macOS version and tried different decompressors for the ZIP file.

Operating information:
Macbook air 2020, OS version 10.15.5
PsychoPy v2022.1.3

Thank you in advance!

Hi there @AMG7,

Would you mind sharing a screenshot of the contents of the unzipped folder here?



Hi @Kimberley_Dundas,

Thank you offering to help, I have now managed to find a solution.
I needed a colleague to compress and send the whole folder as one instead of individual components.



Would you mind sharing some details on this? I have the same problem right now, although not on Mac. I downloaded my own experiment as a whole in .zip format, unzipped it, modified and saved it, but now it wont run cause “the file cannot be found”. Re-saving as a new file also doesn’t help. Thank you in advance!