Change delineator in output file

URL of experiment:

Description of the problem:

The experiment collects multiple individual keyboard key presses as resposes for a single routine. Each key press is an additional response for that routine. This works fine, however the output file uses a comma to delineate columns representing the different output items, such as reaction time and stumulus duration, but also uses a comma to seperate the multiple keyboard responses for a single rountine. In spite of the multiple keyboard responses being contained in square brackets it is not possible to open the output file in excel and have the columns be properly parsed.

Is it possible to specify a different delineator for either the column seperations or the multiple keyboard responses?

Thank you.

I see an option in the Data tab of Experiment Settings for specifying a data file delimiter. Might that help you out? Otherwise you could try storing the data in a MongoDB (option in the dashboard of your experiment on Pavlovia).

Thank you very much. I am sure this will do the trick.

1 Like

Hello, Your solution worked for when the experiment runs on Builder, however once the experiment is uploaded to Pavlovia the output files contain only commas as delineators. Do you know of a way I can cange this to something other than a comma on Pavlovia?

Thank you.


Sorry, I (incorrectly) assumed this would work. I took a look in the codebase, but I see this is something on the level of Pavlovia, so there isn’t a quick fix.

Brainstorming a bit: in most importing software, you can specify characters that enclose fields, like double quotes. Could something like that work out?

For example