Cannot push changes if status set to running

Hi,

W10, PsychoPy version 2022.1.3.

This is for a newly created exp (it’s very minimal), fresh install of psychopy under W10.

As per title, once I set the status to running, I cannot push changes any more regardless if I change the status or not - in my case just adding a single image.

Things I’ve tried but didn’t work:

  1. moved experimental only files to different folder and tried again. The error occurs only when I make a single change otherwise I can push and run the exp online without issues
  2. ensured that I am logged in to psychopy
  3. deleted files such as project.json, userPrefs.cfg, users.cfg
  4. I do not have any subfolders, multiple .psyexp, multiple gits e.t.c.

I get the following error (bold and other formatting not my doing):
P.S. is possible for the admins to let discourse to accept .txt files as attachments? It only makes sense if the backtrace error is saved by default as .txt in PsychoPy.

Thank you in advance for any advice.
UPDATE: the error does not occur with an older version of Psychopy (2021.1.4). Pushes changes and runs without issues.

Traceback (most recent call last):
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\builder\builder.py”, line 1381, in onPavloviaSync
pavlovia_ui.syncProject(parent=self, file=self.filename, project=self.project)
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\pavlovia_ui\project.py”, line 742, in syncProject
dlg.sync()
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\app\pavlovia_ui\sync.py”, line 47, in sync
self.project.sync(self.status)
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\projects\pavlovia.py”, line 759, in sync
self.firstPush(infoStream=infoStream)
File “C:\Program Files\PsychoPy\lib\site-packages\psychopy\projects\pavlovia.py”, line 941, in firstPush
info = self.repo.git.push(’-u’, self.remoteWithToken, ‘master’)
File “C:\Program Files\PsychoPy\lib\site-packages\git\cmd.py”, line 638, in
return lambda *args, *kwargs: self._call_process(name, *args, kwargs)
File “C:\Program Files\PsychoPy\lib\site-packages\git\cmd.py”, line 1183, in _call_process
return self.execute(call, exec_kwargs)
File “C:\Program Files\PsychoPy\lib\site-packages\git\cmd.py”, line 983, in execute
raise GitCommandError(redacted_command, status, stderr_value, stdout_value)
git.exc.GitCommandError: Cmd(‘C:\Program Files\PsychoPy\MinGit\cmd\git.exe’) failed due to: exit code(1)
cmdline: C:\Program Files\PsychoPy\MinGit\cmd\git.exe push -u https://oauth2:
@gitlab.pavlovia.org/Yiannis_A/a4_loops_feedback master
stderr: ‘warning: redirecting to https://gitlab.pavlovia.org/Yiannis_A/a4_loops_feedback.git/
To Sign in · GitLab
! [rejected] master → master (fetch first)
error: failed to push some refs to ‘Sign in · GitLab
hint: Updates were rejected because the remote contains work that you do
hint: not have locally. This is usually caused by another repository pushing
hint: to the same ref. You may want to first integrate the remote changes
hint: (e.g., ‘git pull …’) before pushing again.
hint: See the ‘Note about fast-forwards’ in ‘git push --help’ for details.’